Command buttons not working properly when exit and re-join match


#1

And another thing…the run walk fire and them buttons seem a bit slower and if you accidentally exit a battle you cannot get right back in like before…have to close the game reopen and then…if you are extremely fast!


What the hell now
#2

Do you mean that if you issue a movement command, then exit and re-join the match, it takes a while before you see the command again?


#3

No its two different issues:

  1. command buttons feel slower, lie it takes a second for them to react, if you understand what I mean!

  2. If I accidently press “x” button to leave game (I did it a couple of times when I wanted to enter the forum and the buttons are close to each other), I cannot reenter immidiately and save my game! I have to close down the whole app and then reopen and then I can reenter my game!

The issue with the command buttons is not that serious, but still, if you are facing a fast reacting player it feels inhibbiting!

Take care


#4

Regarding 2, what happens when you try to reenter, does it take too long time or doesn’t it work at all?


#5

If I am extremely fast in closing and reopening the app, I have been able to salvage one game (even though it took a serious effort to rally the routing troops)! So yes after reopening the app one can reenter…


#6

And another thing! I have a really hard time finding the aim on range units lately…full zoom! 60% of the time am moving the map and my finger is right there on the aim it feels! Is it only me…my device…it feels like it was abit easier…the whole touchscreen feel! like it was reacting faster!


#7

And also Nikodil! I was thinking about some improvements that maybe not that difficult to make, a bit of polish (not that I have the slightest idea of what writing code is about):

  1. maybe a slight blood animation
  2. in custom, to be able to setup troops individually for each team aswell, so that armies with different prperties can face each other that would be jävla coolt!

I have a few other ideas, but one thing at a time, I know ur working hard!


#8
  1. Improved graphics, including animations, is further down on the to-do list
  2. Yes, each player should be able to pick units at the start of the match

#9

And lately the glitch…has been a bitch! It has become a monster…it paralises the troops, throws u out of the game…unplayable kind of often lately


#10

Also could we add general units to sandbox mode? Think it’s already possible on mobile but I use computer and it’s kinda annoying 4 some battle scenarios I’m wanting 2 do. Should be pretty easy to do.


#11

I also notice opponents are sometimes stuck and cannot move…often it seems that one party is effected by the glitch while the other one can operate!


#12

And just now as I was in a battle where my opponent seemed glitch-paralised and I was in the forum writing the previous post…

1st my opponent quit as I saw “victory/defeat” in the top screen over the forum, then I was thrown out of the game, instead of my avatar it said “logg in” in the top middle of the screen (still with the forum open), then the forum went all white…then I closed the forum and my avatar came back in the middle top of the screen…but without the matches and available games on the right side of the screen…then the forum became normal!

This happens quite a bit lately and one has to restart the app to go back to normal!

Sorry I feel am complaining all the time but…


#13

Thanks for reporting, it’s not supposed to do that, and if you say it’s becoming more frequent I will put focus on investigating and fixing this. I’ve added some network logging on the servers and I notice that there are sometimes unnatural spikes of lost packages, seems there’s something wrong with the networking code.


#14

much appreciated


#15

on a positive note nikodil the command buttons are as smooth as ever! Did unsomehow adress that?


#16

Command lag is likely network related too


#17

ok, I was thinking it might be


#18

Now I notice something else, this could be a bit complicated though! As I have a few archers units left and the opponent infantry and I run and kite accordingly with my fast archers…all of a sudden they glitch and stop responding! Of course they get chased down and cut down and I lose the battle!
It happened so inconveniently for and conveniently for my opponent, that I in my frustration start thinking that some higher power is messing with my game!
Then as I exit to the lobby I see that I am invited to another game so my avatar is both in the game I just left and in the new game I have been invited to. Could it be that the invitation caused the glitch? The game was running smoothly up untill then…

Like here the player is playing a game and he gets an invitation by me, so his avatar is in two places:


#19

And actually that player did notice a glitch…that is kind of serious!